『算法-ACM竞赛-POJ』1287Networking垃圾题目

『算法-ACM 竞赛-POJ』1287Networking 垃圾题目

POJ 1287 Networking 垃圾题目

| Networking Time Limit: 1000MS Memory Limit: 10000KTotal Submissions: 22362 Accepted: 11372Description You are assigned to design network connections between certain points in a wide area. You are given a set of points in the area, and a set of possible routes for the cables that may connect pairs of points. For each possible route between two points, you are given the length of the cable that is needed to connect the points over that route. Note that there may exist many possible routes between two given points. It is assumed that the given possible routes connect (directly or indirectly) each two points in the area. Your task is to design the network for the area, so that there is a connection (direct or indirect) between every two points (i.e., all the points are interconnected, but not necessarily by a direct cable), and that the total length of the used cable is minimal. Input The input file consists of a number of data sets. Each data set defines one required network. The first line of the set contains two integers: the first defines the number P of the given points, and the second the number R of given routes between the points. The following R lines define the given routes between the points, each giving three integer numbers: the first two numbers identify the points, and the third gives the length of the route. The numbers are separated with white spaces. A data set giving only one number P=0 denotes the end of the input. The data sets are separated with an empty line. The maximal number of points is 50. The maximal length of a given route is 100. The number of possible routes is unlimited. The nodes are identified with integers between 1 and P (inclusive). The routes between two points i and j may be given as i j or as j i. Output For each data set, print one number on a separate line that gives the total length of the cable used for the entire designed network. Sample Input 1 0 2 3 1 2 37 2 1 17 1 2 68 3 7 1 2 19 2 3 11 3 1 7 1 3 5 2 3 89 3 1 91 1 2 32 5 7 1 2 5 2 3 7 2 4 8 4 5 11 3 5 10 1 5 6 4 2 12 0 Sample Output 0 17 16 26 Source Southeastern Europe 2002 | Time Limit: 1000MS | | Memory Limit: 10000K | Total Submissions: 22362 | | Accepted: 11372 |
| Time Limit: 1000MS | | Memory Limit: 10000K |
| Total Submissions: 22362 | | Accepted: 11372 |

#include<iostream>
#include<queue>
#include<algorithm>
#include<set>
#include<cmath>
#include<vector>
#include<map>
#include<stack>
#include<bitset>
#include<cstdio>
#include<cstring>
//---------------------------------Sexy operation--------------------------//

#define cini(n) scanf("%d",&n)
#define cinl(n) scanf("%lld",&n)
#define cinc(n) scanf("%c",&n)
#define cins(s) scanf("%s",s)
#define coui(n) printf("%d",n)
#define couc(n) printf("%c",n)
#define coul(n) printf("%lld",n)
#define debug(n) printf("%d_________________________________\n",n);
#define speed ios_base::sync_with_stdio(0)
#define file  freopen("input.txt","r",stdin);freopen("output.txt","w",stdout)
//-------------------------------Actual option------------------------------//
#define rep(i,a,n) for(int i=a;i<=n;i++)
#define per(i,n,a) for(int i=n;i>=a;i--)
#define Swap(a,b) a^=b^=a^=b
#define Max(a,b) (a>b?a:b)
#define Min(a,b) a<b?a:b
#define mem(n,x) memset(n,x,sizeof(n))
#define mp(a,b) make_pair(a,b)
#define pb(n)  push_back(n)
#define dis(a,b,c,d) ((double)sqrt((a-c)*(a-c)+(b-d)*(b-d)))
//--------------------------------constant----------------------------------//

#define INF  0x3f3f3f3f
#define esp  1e-9
#define PI   acos(-1)
using namespace std;
typedef pair<int,int>PII;
typedef pair<string,int>PSI;
typedef  long long ll;
//___________________________Dividing Line__________________________________/

int n,m;
int father[1100000];
struct node
{
    int x;
    int y;
    int k;
}Q[1100000];
int find(int x)
{
    if(father[x]==x)
    return x;
    return father[x]=find(father[x]);
}
bool cmp(node a,node b)
{
    return a.k<b.k;
}
int main()
{
    while(~scanf("%d",&n)&&n)
    {
        cini(m);
        int cont=0,sum=0,st=0;
        for(int i=0;i<m;i++)
        {
            scanf("%d %d %d",&Q[i].x,&Q[i].y,&Q[i].k);
            cont+=Q[i].k;
        }
        sort(Q,Q+m,cmp);
        for(int i=1;i<=n;i++) father[i]=i;
        for(int i=0;i<m;i++)
        {
            int tx=find(Q[i].x);
            int ty=find(Q[i].y);
            if(tx!=ty)
            {
                sum+=Q[i].k;
                st++;
                father[tx]=ty;
                if(st==n-1)
                break;
            }
        }
       printf("%d\n",sum);
    }
    return 0;
}

『算法-ACM竞赛-POJ』1287Networking垃圾题目
https://chiamzhang.github.io/2024/06/29/『算法-ACM竞赛-POJ』1287Networking垃圾题目/
Author
Chiam
Posted on
June 29, 2024
Licensed under