『算法-ACM竞赛-数学-数论』hdu 6216 A Cubic number and A Cubic Number (公式推导)

『算法-ACM 竞赛-数学-数论』hdu 6216 A Cubic number and A Cubic Number (公式推导)

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
A cubic number is the result of using a whole number in a multiplication three times.
For example, 3×3×3=27 so 27 is a cubic number. The first few cubic numbers are 1,8,27,64 and 125.
Given an prime number p. Check that if p is a difference of two cubic numbers.

````

**Input**

```bash
The first of input contains an integer T (1≤T≤100) which is the total number of test cases.
For each test case, a line contains a prime number p (2≤p≤1012).
Output
For each test case, output 'YES' if given p is a difference of two cubic numbers, or 'NO' if not.
````

**Sample Input**

```bash
10
2
3
5
7
11
13
17
19
23
29

Sample Output

1
2
3
4
5
6
7
8
9
10
NO
NO
NO
YES
NO
NO
NO
YES
NO
NO

在这里插入图片描述

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
using namespace std;
int main()
{
int T;
scanf("%d", &T);
while (T--)
{
ll n;
scanf("%lld", &n);
if ((n - 1) % 3)
{
printf("NO\n");
continue;
}
ll x = (ll)sqrt((n - 1) / 3);
if (x * (x + 1) == (n - 1) / 3)
printf("YES\n");
else
printf("NO\n");
}
return 0;
}

『算法-ACM竞赛-数学-数论』hdu 6216 A Cubic number and A Cubic Number (公式推导)
https://chiamzhang.github.io/2024/06/29/『算法-ACM竞赛-数学-数论』hdu 6216 A Cubic number and A Cubic Number (公式推导)/
Author
Chiam
Posted on
June 29, 2024
Licensed under