『算法-ACM竞赛-数学-数论』 HDU 2601 An easy problem(约束和)

『算法-ACM 竞赛-数学-数论』 HDU 2601 An easy problem(约束和)

Problem Description

1
2
3
4
5
6
7
When Teddy was a child , he was always thinking about some simple math problems ,such as “What it’s 1 cup of water plus 1 pile of dough ..” , “100 yuan buy 100 pig” .etc..
One day Teddy met a old man in his dream , in that dream the man whose name was“RuLai” gave Teddy a problem :

Given an N , can you calculate how many ways to write N as i * j + i + j (0 < i <= j) ?

Teddy found the answer when N was less than 10…but if N get bigger , he found it was too difficult for him to solve.
Well , you clever ACMers ,could you help little Teddy to solve this problem and let him have a good dream ?
BASH

Input

1
The first line contain a T(T <= 2000) . followed by T lines ,each line contain an integer N (0<=N <= 1010).
BASH

Output

1
For each case, output the number of ways in one line.
BASH

Sample Input

1
2
3
2
1
3
BASH

Sample Output

1
2
0
1
BASH

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
using namespace std;

int main(){
int t;
long long n,i,j,ans;
scanf ("%d",&t);
while (t--){
ans=0;
scanf ("%lld",&n);
n++;
for (i=2;i*i<=n;i++){
if (n%i==0)
ans++;
}
printf ("%lld\n",ans);
}
return 0;
}
CPP

『算法-ACM竞赛-数学-数论』 HDU 2601 An easy problem(约束和)
https://chiamzhang.github.io/2024/06/29/『算法-ACM竞赛-数学-数论』 HDU 2601 An easy problem(约束和)/
Author
Chiam
Posted on
June 29, 2024
Licensed under
Powered By Valine
v1.5.1