『算法-ACM竞赛-搜索』HDU-1253胜利大逃亡(搜索)

『算法-ACM 竞赛-搜索』HDU-1253 胜利大逃亡(搜索)

HDU - 1253 胜利大逃亡(搜索)

Ignatius 被魔王抓走了,有一天魔王出差去了,这可是 Ignatius 逃亡的好机会.

魔王住在一个城堡里,城堡是一个 ABC 的立方体,可以被表示成 A 个 B*C 的矩阵,刚开始 Ignatius 被关在(0,0,0)的位置,离开城堡的门在(A-1,B-1,C-1)的位置,现在知道魔王将在 T 分钟后回到城堡,Ignatius 每分钟能从一个坐标走到相邻的六个坐标中的其中一个.现在给你城堡的地图,请你计算出 Ignatius 能否在魔王回来前离开城堡(只要走到出口就算离开城堡,如果走到出口的时候魔王刚好回来也算逃亡成功),如果可以请输出需要多少分钟才能离开,如果不能则输出-1.

Input

输入数据的第一行是一个正整数 K,表明测试数据的数量.每组测试数据的第一行是四个正整数 A,B,C 和 T(1<=A,B,C<=50,1<=T<=1000),它们分别代表城堡的大小和魔王回来的时间.然后是 A 块输入数据(先是第 0 块,然后是第 1 块,第 2 块……),每块输入数据有 B 行,每行有 C 个正整数,代表迷宫的布局,其中 0 代表路,1 代表墙.(如果对输入描述不清楚,可以参考 Sample Input 中的迷宫描述,它表示的就是上图中的迷宫)

特别注意:本题的测试数据非常大,请使用 scanf 输入,我不能保证使用 cin 能不超时.在本 OJ 上请使用 Visual C++提交.

Output

对于每组测试数据,如果 Ignatius 能够在魔王回来前离开城堡,那么请输出他最少需要多少分钟,否则输出-1.

Sample Input

1
3 3 4 20
0 1 1 1
0 0 1 1
0 1 1 1
1 1 1 1
1 0 0 1
0 1 1 1
0 0 0 0
0 1 1 0
0 1 1 0

Sample Output

11

三维搜索,数据量不大,利用不超过 T 的时间剪枝即可,优化时间。

因为是多组输入所以慎用 return 0,wa 了 7 遍。

#include<iostream>
#include<queue>
#include<algorithm>
#include<set>
#include<cmath>
#include<vector>
#include<map>
#include<stack>
#include<bitset>
#include<cstdio>
#define Swap(a,b) a^=b^=a^=b
#define cini(n) scanf("%d",&n)
#define cinl(n) scanf("%lld",&n)
#define cinc(n) scanf("%c",&n)
#define coui(n) printf("%d",n)
#define couc(n) printf("%c",n)
#define coul(n) printf("%lld",n)
#define speed ios_base::sync_with_stdio(0);
#define Max(a,b) a>b?a:b
#define Min(a,b) a<b?a:b
using namespace std;
typedef long long ll;
const int INF=0x3f3f3f3f;
const int maxn=1e6+10;
const double esp=1e-9;
int m,n,s,x,y,z,A,B,C;
int ob[51][51][51];
struct lo
{
    int x,y,z,cnt;
    lo(int a,int b,int c,int cnt ):x(a),y(b),z(c),cnt(cnt){}
};
int fx[6][3]={{1,0,0},{0,1,0},{0,0,1},{-1,0,0},{0,-1,0},{0,0,-1}};
int main()
{
    int T;
    cini(T);
    while(T--)
    {
        cini(A);
        cini(B);
        cini(C);
        cini(s);
        for(int i=0;i<A;i++)
            for(int j=0;j<B;j++)
                for(int k=0;k<C;k++)
                    cini(ob[i][j][k]);
        //while(cin>>x>>y>>z) cout<<ob[x][y][z]<<endl;
        queue<lo> q;
        while(!q.empty()) q.pop();
        q.push(lo(0,0,0,0));
        ob[0][0][0]=1;
        while(!q.empty())
        {
            lo tem=q.front();
            int a=tem.x;
            int b=tem.y;
            int c=tem.z;
            int cnt=tem.cnt;
            if(a==A-1&&b==B-1&&c==C-1)
            {
                printf("%d\n",cnt);
                goto loop;
            }
            q.pop();
            for(int i=0;i<6;i++)
            {
                if(a+fx[i][0]<0||a+fx[i][0]>=A||b+fx[i][1]<0||b+fx[i][1]>=B||c+fx[i][2]>=C||c+fx[i][2]<0) continue;
                if(ob[a+fx[i][0]][b+fx[i][1]][c+fx[i][2]]==0&&cnt+1<=s)
                {
                  // cout<<a+fx[i][0]<<' '<<b+fx[i][1]<<' '<<c+fx[i][2]<<endl;
                    ob[a+fx[i][0]][b+fx[i][1]][c+fx[i][2]]=1;
                    q.push(lo(a+fx[i][0],b+fx[i][1],c+fx[i][2],cnt+1));
                }
            }
        }
       printf("-1\n");
       loop:continue;
    }

}

『算法-ACM竞赛-搜索』HDU-1253胜利大逃亡(搜索)
https://chiamzhang.github.io/2024/06/29/『算法-ACM竞赛-搜索』HDU-1253胜利大逃亡(搜索)/
Author
Chiam
Posted on
June 29, 2024
Licensed under